APAC autopay delay
Incident Report for MINDBODY
Resolved
This incident has been resolved
Posted 27 days ago. Aug 22, 2019 - 21:22 PDT
Monitoring
Some clients in Asia Pacific may receive autopays in day late due to a delay in processing. The issue is being monitored and further updates will be provided as required..
Posted 27 days ago. Aug 22, 2019 - 21:12 PDT
This incident affected: Payment Processing.