Support Center - Contact Numbers Drop Box
Incident Report for MINDBODY
Resolved
Our earlier issue affecting clients accessing the drop down menu for contact numbers in our Support Center is now resolved. Thank you for your patience as we restored services.
Posted Feb 17, 2020 - 13:52 PST
Investigating
Customers are currently unable to access the drop down menu for contact numbers in our Support Center. You can access the full list of contact numbers for each country by logging into your MINDBODY Site - Click on the Help Button in the top right of the screen - Select contact us - Click on Phone and the drop box of contact numbers will be available.
Posted Feb 17, 2020 - 05:23 PST
This incident affected: MINDBODY corporate site.