Merchant Account Processing - Identified
Incident Report for Mindbody
Resolved
The previous Ezidebit issue impacting subscribers from processing real-time transactions is now resolved. Thank you for your patience while Ezidebit worked to restore service to full functionality.
Posted Oct 11, 2020 - 23:45 PDT
Investigating
Ezidebit is currently experiencing a system degradation. Subscribers who utilize Ezidebit may experience real-time transaction failures.
Posted Oct 11, 2020 - 23:07 PDT
This incident affected: Mindbody Payment Processing.