MINDBODY Customer Support Inbound Call Queue
Incident Report for Mindbody
Resolved
This incident has been resolved, and the customer support call queue is now operational.
Posted Apr 22, 2020 - 04:26 PDT
Identified
MINDBODY's Customer Support Inbound Call Queue is currently experiencing issues with connectivity. We are aware of this and are actively working to resolve the issue. Wait times may increase during this time. Alternatively, you may contact us by email at support@mindbodyonline.com
Posted Apr 22, 2020 - 03:32 PDT
This incident affected: Mindbody web software.