MINDBODY Support Website
Incident Report for MINDBODY
Resolved
This incident has been resolved.
Posted Feb 16, 2020 - 20:21 PST
Identified
MINDBODY customers may experience slow page load times or be unable to access support.mindbodyonline.com. Please continue to monitor the MINDBODY Status Page for updates.
Posted Feb 16, 2020 - 19:00 PST
This incident affected: MINDBODY corporate site.