MINDBODY Customer using Elavon payment processing
Incident Report for MINDBODY
Resolved
Our previous issues with Elavon payment processing have been resolved and we have returned to full functionality. We apologize for the inconvenience that this has caused.
Posted 5 months ago. Apr 01, 2019 - 15:22 PDT
Investigating
Some MINDBODY customers using the Elavon payment processing service are experiencing intermittent issues. We are currently working with Elavon to identify a solution. We apologize the inconvenience that this is causing and hope to return to full functionality soon.
Posted 5 months ago. Apr 01, 2019 - 10:54 PDT
This incident affected: Payment Processing.