Insights
Incident Report for Mindbody
Resolved
Between 8:47 AM PDT and 8:49 PDT, Mindbody Subscribers were unable to access insights reporting. We apologize for any inconvenience this may have caused.
Posted May 26, 2022 - 09:50 PDT
Investigating
We are investigating an issue impacting Insights. Thank you for your patience while we work to restore services. Our next update will be at 10:00 AM PDT.
Posted May 26, 2022 - 09:30 PDT