EziDebit - Merchant Processing
Incident Report for MINDBODY
Resolved
EziDebit has found and resolved the issue with payments failing. Merchant Payments are processing without any issues.
Posted 2 months ago. Apr 10, 2019 - 01:27 PDT
Update
EziDebit are still experiencing issues with merchant transactions - However the number of failures is reducing and they are still working on a resolution.
Posted 2 months ago. Apr 10, 2019 - 01:14 PDT
Investigating
EziDebit are currently experiencing issues with all merchant transactions. They are aware of the situation and are currently looking into this.
Posted 2 months ago. Apr 10, 2019 - 00:22 PDT
This incident affected: Payment Processing.