Customer Service Inbound Calls - Sheffield - Power Outage
Incident Report for MINDBODY
Resolved
We have regained power in the Sheffield Customer Service office. All services are now operational.
Posted Nov 26, 2019 - 01:46 PST
Identified
We are currently experiencing a power outage in our Sheffield Service Support Office. Wait times will be longer than usual. We are working on getting this resolved as soon as possible.
Posted Nov 26, 2019 - 01:27 PST
This incident affected: MINDBODY web software.