Mindbody One
Incident Report for Mindbody
Resolved
This incident has been resolved.
Posted Aug 22, 2020 - 06:45 PDT
Investigating
Mindbody subscribers are currently unable to access Mindbody One community. We are working with our hosting provider to expedite a quick resolution. Thank you for your understanding!
Posted Aug 22, 2020 - 01:36 PDT