EziDebit - Merchant Processing
Incident Report for MINDBODY
Resolved
This incident has been resolved.
Posted 4 days ago. Apr 17, 2019 - 12:29 PDT
Monitoring
Some customers who are using EziDebit merchant processing may experience some delay in auto-payment processing. Please allow up to 24 hours for transactions to post. We apologize for any inconvenience that this has caused.
Posted 4 days ago. Apr 17, 2019 - 10:31 PDT
This incident affected: Payment Processing.