Payment Processing
Incident Report for Mindbody
Resolved
Ezidebit's previous issue impacting Mindbody payment is now resolved. Thank you for your patience while Ezidebit worked to restore service to full functionality.
Posted Apr 21, 2021 - 18:55 PDT
Investigating
Our payment processing vendor Ezidebit is experiencing a partial outage with API transactions in the New Zealand and Australia regions. We will continue to provide updates as we receive them from Ezidebit.
Posted Apr 21, 2021 - 18:47 PDT
This incident affected: Mindbody Payment Processing.