Marketing Suite Scheduled Maintenance
Complete·Under maintenance·Oct 14, 6:30 AM - 1:04 PM

The maintenance has successfully completed.

Tue, Oct 14, 2025, 01:04 PM
(1 week ago)
·
Affected components
Marketing Suite
Updates

Complete

The maintenance has successfully completed.

Tue, Oct 14, 2025, 01:04 PM

In progress

We’re extending the scheduled maintenance for Marketing Suite to 3:30 AM PT as we wrap up the final steps. Thanks so much for your patience — we’re working hard to bring everything back online as soon as possible.

Tue, Oct 14, 2025, 08:35 AM(4 hours earlier)

In progress

We’ve extended the scheduled maintenance for Marketing Suite by one hour and now expect it to be completed by 1:30 AM PT. We apologize for the inconvenience and appreciate your patience.

Tue, Oct 14, 2025, 07:37 AM(57 minutes earlier)

Complete

Maintenance has completed

Tue, Oct 14, 2025, 07:30 AM

In progress

Maintenance has started

Tue, Oct 14, 2025, 06:30 AM(1 hour earlier)

Scheduled

We’ve scheduled maintenance on Sunday, October 13, 2025, from 11:30 PM to Monday, October 14, 2025, 12:30 AM Pacific Time.

During the maintenance, Marketing Suite will be temporarily unavailable. We expect downtime to be minimal, and all services will resume automatically once the maintenance is complete. Any communications that were scheduled during that period will be queued and sent when Marketing Suite service resumes.

Fri, Oct 10, 2025, 06:50 PM(3 days earlier)