Mindbody Web Software
Resolved·Partial outage

Our engineering teams have successfully implemented a fix and the Mindbody Web Software has been restored to full functionality. Thank you for your patience while we worked to restore services.

Thu, Oct 16, 2025, 02:50 PM
(1 week ago)
·
Affected components
Updates

Resolved

Our engineering teams have successfully implemented a fix and the Mindbody Web Software has been restored to full functionality. Thank you for your patience while we worked to restore services.

Thu, Oct 16, 2025, 02:50 PM

Investigating

We are investigating an issue impacting the Mindbody Web Software. Some Mindbody customers may experience an issue where classes and related activities are incorrectly shown as past before their scheduled start time. Thank you for your patience while we work to restore services. Our next update will be at 8:00AM PT.

Thu, Oct 16, 2025, 01:48 PM(1 hour earlier)