Mindbody, Booker, and FitMetrix Services
Resolved·Full outage

Cloudflare has resolved their incident and we have verified all Mindbody, Booker, and FitMterix services have successfully recovered.

Fri, Dec 5, 2025, 09:31 AM
(2 weeks ago)
·
Affected components
Insights
Marketing Suite
Messenger[ai]
Updates

Resolved

Cloudflare has resolved their incident and we have verified all Mindbody, Booker, and FitMterix services have successfully recovered.

Fri, Dec 5, 2025, 09:31 AM

Monitoring

The 3rd party cloud provider, Cloudflare, has begun remedial actions and services are beginning to come back online. There may be slower than normal page load times or intermittent errors while our services recover. We are closely monitoring services to ensure system stability. Our next update will be at 2:00AM PT.

Fri, Dec 5, 2025, 09:18 AM(12 minutes earlier)

Identified

We have identified a 3rd party upstream cloud provider impacting Mindbody, Booker, and FitMetrix. Currently Mindbody, Booker, and FitMetrix is unavailable. We're working with the cloud provider to bring services back online as soon as possible. Our next update will be at 2:00AM PT.

Fri, Dec 5, 2025, 09:11 AM