Payment Processing - Mindbody Payments
Monitoring·Degraded performance

The 3rd party upstream payment processor has identified the cause of increased Visa and MasterCard declines for Mindbody Payments customers and working to resolve the issue.

Mindbody customers in the EUR region using Mindbody Payments may experience an "Invalid account number" or "Invalid credentials" decline code when attempting to process Visa or MasterCard credit cards.

We will continue to provide updates as received to this issue. In the meantime, if you experience an invalid decline, please reach out to your card issuer or wait until the issue has been resolved.

Tue, Feb 3, 2026, 11:20 PM
(2 days ago)
·
Affected components
Updates

Monitoring

The 3rd party upstream payment processor has identified the cause of increased Visa and MasterCard declines for Mindbody Payments customers and working to resolve the issue.

Mindbody customers in the EUR region using Mindbody Payments may experience an "Invalid account number" or "Invalid credentials" decline code when attempting to process Visa or MasterCard credit cards.

We will continue to provide updates as received to this issue. In the meantime, if you experience an invalid decline, please reach out to your card issuer or wait until the issue has been resolved.

Tue, Feb 3, 2026, 11:20 PM

Monitoring

We've identified a 3rd party upstream payment processor experiencing an issue. Mindbody customers in the EUR region using Mindbody Payments may experience an "Invalid account number" or "Invalid credentials" decline code when attempting to process Visa or MasterCard credit cards.

We will provide updates as received to this issue. In the meantime, if you experience an invalid decline, please reattempt to process or wait until the issue has been resolved.

Thu, Jan 29, 2026, 10:02 PM(5 days earlier)