Mindbody

Report a problemSubscribe to updates
Powered by
Terms of service
SEPA Payment Processing Disruption (Partial Impact)
Resolved·Degraded performance

Resolved - SEPA Transaction Processing

The issue affecting SEPA transactions has been resolved.

The disruption was caused by an incident with our third-party payment provider, Stripe, which has now been fully addressed. Payment processing has returned to normal.

Impacted Autopays will automatically reattempt within 24h.

If you prefer not to wait, you may manually rerun the affected transactions directly from the Autopay Detail Report.

We apologize for the inconvenience and appreciate your patience while this issue was being resolved.

Sun, Mar 1, 2026, 06:45 PM
(2 months ago)
·
Affected components
Mar 1, 2026, 04:42 PM
06:45 PM
Updates

Resolved

Resolved - SEPA Transaction Processing

The issue affecting SEPA transactions has been resolved.

The disruption was caused by an incident with our third-party payment provider, Stripe, which has now been fully addressed. Payment processing has returned to normal.

Impacted Autopays will automatically reattempt within 24h.

If you prefer not to wait, you may manually rerun the affected transactions directly from the Autopay Detail Report.

We apologize for the inconvenience and appreciate your patience while this issue was being resolved.

Sun, Mar 1, 2026, 06:45 PM

Investigating

We are currently investigating an issue affecting SEPA transactions for a subset of customers.

Some SEPA payments are not being processed as expected. Our engineering team is actively working to identify the root cause and restore full functionality as quickly as possible.

We understand the importance of timely payment processing and apologize for the inconvenience this may cause. We will provide further updates as soon as more information becomes available.

Sun, Mar 1, 2026, 04:42 PM(2 hours earlier)