Resolved
The issue affecting Mindbody has been resolved. All services are operating normally. We apologize for the disruption and thank you for your patience. If you continue to experience issues, please contact support.
Investigating
We are aware of degraded performance affecting Mindbody. Our team is investigating. We will update this page as we learn more.