Resolved
The issue impacting Marketing Suite has been fully resolved. A fix has been successfully deployed, and access has been restored for all affected regions.
We sincerely apologize for the disruption this caused and appreciate your patience while our engineering teams worked to resolve the issue. If you continue to experience any problems accessing Marketing Suite, please contact our support team.
Resolved
Resolved
The issue impacting Marketing Suite has been fully resolved. A fix has been successfully deployed, and access has been restored for all affected regions.
We sincerely apologize for the disruption this caused and appreciate your patience while our engineering teams worked to resolve the issue. If you continue to experience any problems accessing Marketing Suite, please contact our support team.
Identified
Our engineering teams have identified the issue impacting Marketing Suite. We’re working to roll out a fix. Thank you for your patience!
Investigating
We are investigating an issue impacting Marketing Suite. Some customers are unable to access Marketing Suite dependent upon region. Thank you for your patience while we work to restore services!