Complete
Maintenance has completed
In progress
Scheduled Booker Maintenance will continue until 2:00am June 21, 2026.
During the start of this window, Booker customers will be unable to access Booker services from 8:00 PM PT to 10:00 PM PT, followed by continued maintenance with minor disruptions until 2:00 AM PT. Thanks for bearing with us while we work to keep things smooth, safe, and quick!
If you experience site performance problems outside of this maintenance window, please see our [site performance troubleshooting guide](https://support.mindbodyonline.com/s/article/ka0320000000PRMAA2/217451777-What-to-do-if-you-feel-that-your-MINDBODY-site-is-responding-slowly-or-not-loading).
For contact info and additional support resources, please check out our [knowledge base](https://support.mindbodyonline.com/hc/en-us).
In progress
Maintenance has started
Scheduled
We've scheduled Booker maintenance on Saturday, June 20th, 2026, from 8:00 PM Pacific Time to Sunday, June 21st, 2026, 01:00 AM Pacific Time. During the start of this window, Booker customers will be unable to access Booker services from 8:00 PM PT to 10:00 PM PT, followed by continued maintenance with minor disruptions until 1:00 AM PT. Thanks for bearing with us while we work to keep things smooth, safe, and quick!
If you experience site performance problems outside of this maintenance window, please see our [site performance troubleshooting guide](https://support.mindbodyonline.com/s/article/ka0320000000PRMAA2/217451777-What-to-do-if-you-feel-that-your-MINDBODY-site-is-responding-slowly-or-not-loading).
For contact info and additional support resources, please check out our [knowledge base](https://support.mindbodyonline.com/hc/en-us).