Resolved
Our engineering teams have successfully implemented a fix and the previous impact has been resolved.
Thank you for your patience!
Investigating
We are investigating an issue impacting the Mindbody Web Software. Some Mindbody customers are experiencing slower than normal page load times and errors when attempting to load the appointments tab within the Mindbody Web Software.
Thank you for your patience while we work to restore services. Our next update will be at 3:30 PM PT.