Payment Processor - Ezidebit - Real Time Transaction delays
Incident Report for MINDBODY
Resolved
Ezidebit has resolved their incident and services have restored to full functionality.
Posted Jan 03, 2020 - 21:55 PST
Update
Customers using Ezidebit in Asia Pacific region may experience delays or errors with real time transactions. Ezidebit has acknowledged and identified an issue with real time payments processing and is currently working on a resolution.
Posted Jan 03, 2020 - 20:27 PST
Identified
Customers using Ezidebit in Asia Pacific region may experience delays or errors with real time transactions. Ezidebit is aware and we are currently awaiting a response for additional information.
Posted Jan 03, 2020 - 19:38 PST
Investigating
Customers using Ezidebit in Asia Pacific region may experience delays or errors with real time transactions. Ezidebit is aware and we are currently awaiting a response for additional information.
Posted Jan 03, 2020 - 19:33 PST
This incident affected: Payment Processing.