Booker Payment Processing
Incident Report for Mindbody
Resolved
Clover has resolved their previous issue impacting Booker Payment Processing. Thank you for your patience while Clover worked to restore payment services.
Posted Nov 01, 2023 - 14:46 PDT
Update
Booker customers using Clover as their payment processor can contact Clover's US support line (1-866-583-0959) for more information or continue to check here for additional updates as we receive them.
Posted Nov 01, 2023 - 11:59 PDT
Monitoring
We have identified an upstream payment processor, Clover, impacting Booker Payment Processing. Booker customers using Clover as their payment processor are unable to process payments. We are working with the payment processor, Clover, to restore payment services as soon as possible. Our next update will be at 1:00PM PDT.
Posted Nov 01, 2023 - 11:40 PDT
This incident affected: Booker (Booker Payment Processing).