Ezidebit Real Time Transactions - Degradation
Incident Report for MINDBODY
Resolved
Ezidebit has resolved issues and services have restored to full functionality.
Posted Feb 17, 2020 - 18:46 PST
Identified
EziDebit is currently experiencing issues with timeouts impacting transactions to MINDBODY clients using EziDebit. Users may experience failed transactions when attempting to process payments. Please continue to monitor the MINDBODY Status Page for further updates.
Posted Feb 17, 2020 - 17:45 PST
This incident affected: Payment Processing.