Mindbody - Lead Management
Incident Report for Mindbody
Resolved
Our engineering team has implemented a fix and Mindbody Lead Management has been fully restored. Thank you for your patience while we worked to restore services.
Posted Nov 18, 2024 - 11:35 PST
Investigating
We are investigating an issue impacting Mindbody Lead Management. Mindbody customers with the lead management feature are currently not seeing any leads. Thank you for your patience while we work to restore services. Our next update will be at 12:00PM PT.
Posted Nov 18, 2024 - 10:59 PST
This incident affected: Mindbody (Mindbody Web Software - Asia Pacific, Mindbody Web Software - Europe, Middle East, and Africa, Mindbody Web Software - North, Central, and South America).