Booker Web Software
Incident Report for Mindbody
Resolved
Between 02:57 PM PDT and 04:00 PM PDT Booker Subscribers may have experienced issues while logging into Booker Web Software. Booker Subscribers may have experienced slower than normal page load times while navigating through Booker Web Software. We apologize for any inconvenience caused.
Posted Aug 12, 2023 - 16:34 PDT
Investigating
We are investigating an issue impacting Booker Web Software. Thank you for your patience while we work to restore services. Our next update will be at 04:30 PM PDT.
Posted Aug 12, 2023 - 15:56 PDT
This incident affected: Booker (Booker Web Software).