Mindbody Payment Processing - Delayed Scheduled Deposits.
Incident Report for Mindbody
Resolved
We have identified the root cause issue impacting Mindbody Payment Processing. Mindbody customers located in Canada have received their scheduled deposits on Tuesday (4/16). Thank you for your patience while we worked to restore service.
Posted Apr 16, 2024 - 07:23 PDT
Investigating
We have identified the root cause issue impacting Mindbody Payment Processing. Mindbody customers located in Canada have received their scheduled deposits on Tuesday (4/16). Thank you for your patience while we worked to restore service.
Posted Apr 15, 2024 - 08:13 PDT
This incident affected: Mindbody (Mindbody Payment Processing).