Booker Online Booking
Incident Report for Mindbody
Resolved
Booker users are no longer experiencing issues preventing them from booking an appointment online. We appreciate your patience as we worked to resolve the issue.
Posted Jul 20, 2024 - 14:34 PDT
Investigating
Booker users are experiencing issues preventing them from booking an appointment online. Our engineers are currently investigating the issue. We appreciate your patience as we work to restore services.
Posted Jul 20, 2024 - 12:12 PDT
This incident affected: Booker (Booker Online Booking).