Engineers have confirmed the issue impacting Mindbody Web Software has been resolved. Thank you for your patience while we worked to restore services.
Posted Aug 05, 2025 - 15:03 PDT
Monitoring
Our engineering team is actively monitoring the implemented fix to ensure continued system stability.
Thank you for your patience while we worked to restore services.
Posted Aug 05, 2025 - 14:00 PDT
Identified
Our engineering team has implemented a fix and our systems are currently stable. Thank you for your patience while we work to restore services. Our next update will be at 2:00PM PT.
Posted Aug 05, 2025 - 13:08 PDT
Update
We have identified current impact also applies to the Mindbody App. Some Mindbody consumers may experience intermittent issues attempting to log into the Mindbody App.
Our engineering teams are working to implement a fix. Thank your for your patience while we work to restore services.
Our next update will be at 1:00PM PT.
Posted Aug 05, 2025 - 12:06 PDT
Update
Engineers continue to investigate the cause of this issue. Next update will be made at 12:30 PM PT, or as additional information becomes available.
Posted Aug 05, 2025 - 11:30 PDT
Investigating
We are currently in the process of investigating an issue impacting the Mindbody Web Software. At this time, users may experience inconsistent or incomplete page loading.
Next update will be provided at 11:30 AM PT, or as additional information becomes available.
Posted Aug 05, 2025 - 10:52 PDT
This incident affected: Mindbody (Mindbody Web Software - Asia Pacific, Mindbody Web Software - Europe, Middle East, and Africa, Mindbody Web Software - North, Central, and South America, Mindbody App).