The previous issue impacting Booker Payment Processing has been resolved. Between 8:12 AM PST and 8:22 AM PST, Some Booker Subscribers that use Web2Pay as their Payment processor were unable to process any credit card transactions. Thank you for your patience while the third-party payment provider worked to restore service to full functionality.
Resolved
The previous issue impacting Booker Payment Processing has been resolved. Between 8:12 AM PST and 8:22 AM PST, Some Booker Subscribers that use Web2Pay as their Payment processor were unable to process any credit card transactions. Thank you for your patience while the third-party payment provider worked to restore service to full functionality.
Investigating
We are investigating an issue impacting Booker Payment Processing. Thank you for your patience while we work to restore services. Our next update will be at 9:30 AM PST.