Resolved
Our Booker engineering team has successfully implemented a fix and all Booker services have recovered. Thank you for your patience while we restored services.
Investigating
We are continuing to investigate the issue impacting Booker Online Booking. Thank you for your patience while we work to restore services. Our next update will be at 2:00PM PDT.
Investigating
We are investigating an issue impacting Booker Online Booking. Booker consumers are intermittently experiencing an error when attempting to access Booker Online Booking. As a workaround, Booker customers can successfully book consumer appointments through the Booker Web Software. Thank you for your patience while we work to restore services. Our next update will be at 12:30PM PDT.