Mindbody Payment Processing
Incident Report for Mindbody
Resolved
Upon further investigation our engineering teams have confirmed there is no impact to the Mindbody Payment Processing. Thank you for your patience.
Posted Jun 01, 2023 - 07:05 PDT
Investigating
We are investigating an issue impacting Mindbody Payment Processing. Thank you for your patience while we work to restore services. Our next update will be at 07:00 AM PDT.
Posted Jun 01, 2023 - 05:49 PDT
This incident affected: Mindbody (Mindbody Payment Processing).