Payment Processor - Ezidebit - Outage
Incident Report for MINDBODY
Resolved
We have had confirmation from Ezidebit that all services have been fully restored. All customers will now be able to complete transactions without any issues.
Posted Dec 05, 2019 - 03:20 PST
Investigating
Customers using Ezidebit are currently unable to complete transactions. Ezidebit is aware and we are currently awaiting a response for additional information.
Posted Dec 05, 2019 - 03:05 PST
This incident affected: Payment Processing.