Ezidebit has successfully restored payment services to New Zealand Mindbody customers. Thank you for your patience while Ezidebit worked to restore services.
Posted Feb 14, 2025 - 10:09 PST
Update
We are continuing to work with Ezidebit to restore services. We will provide our next update once received by Ezidebit.
Posted Feb 13, 2025 - 13:18 PST
Update
Due to the ongoing issues with Ezidebit, customers in New Zealand may be experiencing autopays with declines showing up in their autopay detail report.
Thank you for your patience while we work with Ezidebit to restore services. Our next update will be at 1:00PM PT.
Posted Feb 13, 2025 - 10:13 PST
Monitoring
Ezidebit is continuing to work on a fix for their New Zealand customers. Thank you for your patience while we work with Ezidebit to restore services. Our next update will be at 12:00PM PT.
Posted Feb 13, 2025 - 09:32 PST
Identified
We have identified a 3rd party payment processor impacting Mindbody Payment Processing. Some Mindbody customers in New Zealand using Ezidebit as their payment processor are intermittently experiencing errors when attempting to process payments. We are working with Ezidebit to restore services as soon as possible. Our next update will be at 9:00AM PT.
Posted Feb 13, 2025 - 06:22 PST
This incident affected: Mindbody (Mindbody Payment Processing).