Mindbody Payment Processing
Incident Report for Mindbody
Resolved
Mindbody customers using TSYS Payment Solutions are no longer experiencing delays with the processing of Credit Card sales made on 9/7 and 9/8. The issue is now resolved. We appreciate your patience as our partners worked to restore services.
Posted Sep 11, 2024 - 08:45 PDT
Identified
We are investigating an issue impacting Mindbody Payment Processing. Mindbody customers using TSYS Payment Solutions are experiencing delays with the processing of Credit Card sales made on 9/7 and 9/8. The deposits are expected to be received on 9/11. We apologize for any inconvenience this may cause and appreciate your patience as our partners work to restore services.
Posted Sep 10, 2024 - 08:25 PDT
This incident affected: Mindbody (Mindbody Payment Processing).