The incident has been fully resolved, thank you for your patience while we worked to restore services.
Posted Jul 29, 2025 - 12:39 PDT
Monitoring
Our engineering teams have implemented a fix and page load times within the Mindbody Web Software are back to normal. We are continuing to monitor the Mindbody Web Software to ensure system stability. Our next update will be at 12:00PM PT.
Posted Jul 29, 2025 - 10:57 PDT
Investigating
We are investigating an issue impacting Mindbody Web Software. Some Mindbody customers may experience slower than normal page load times while navigating through the Mindbody Web Software. Thank you for your patience while we work to restore services. Our next update will be at 11:00AM PT.
Posted Jul 29, 2025 - 10:22 PDT
This incident affected: Mindbody (Mindbody Web Software - Asia Pacific, Mindbody Web Software - Europe, Middle East, and Africa, Mindbody Web Software - North, Central, and South America).