Ezidebit Real Time Transactions - Degradation
Incident Report for Mindbody
Resolved
EziDebit has resolved their payment processor issues. Thank you for your patience!
Posted Aug 30, 2020 - 10:55 PDT
Investigating
EziDebit is currently experiencing issues with its real-time payment processing gateway. Mindbody clients using EziDebit may experience failed transactions when attempting to process payments. Please continue to monitor the Mindbody Status Page for further updates.
Posted Aug 30, 2020 - 04:58 PDT
This incident affected: Mindbody Payment Processing.