PaySafe - Degradation
Incident Report for Mindbody
Resolved
PaySafe has resolved their incident and restored services to full functionality.
Posted Nov 19, 2020 - 16:33 PST
Monitoring
Paysafe Mindbody's payment processing vendor for Europe, the Middle East, and Africa region is intermittently experiencing degradation. Mindbody subscribers using PaySafe as their payment processor could experience real-time transaction failures.
Posted Nov 19, 2020 - 13:13 PST
This incident affected: Mindbody Payment Processing.