Access to Customer Service (Call Volume) - Monitoring
Incident Report for MINDBODY
Resolved
Our phone vendor has confirmed that functionality has returned, we have re-opened the phone and live chat queues. Thank you for your patience.
Posted 2 months ago. May 13, 2018 - 08:02 PDT
Monitoring
We are continuing to experience issues with our phone vendor, we have closed our phone queues and live chat queues for the time being. We will reopen the phone and live chat support queue's as soon as the issue is resolved. For technical support, please use the support page below to submit a case.

https://support.mindbodyonline.com/s/contactsupport?language=en_US
Posted 2 months ago. May 13, 2018 - 07:00 PDT
Update
We are continuing to experience issues with our phone vendor, we have closed our phone queues and live chat queues for the time being. We will reopen the phone and live chat support queue's as soon as the issue is resolved. For technical support, please use the support page below to submit a case.

https://support.mindbodyonline.com/s/contactsupport?language=en_US
Posted 2 months ago. May 13, 2018 - 05:38 PDT
Update
We are continuing to experience issues with out phone vendor, we have closed our phone queues and live chat queues for the time being. We will reopen the phone and live chat support queue's as soon as the issue is resolved. For technical support, please use the support page below to submit a case.

https://support.mindbodyonline.com/s/contactsupport?language=en_US
Posted 2 months ago. May 13, 2018 - 05:15 PDT
Update
We are continuing to experience issues with out phone vendor, this may result in longer wait times, if you are having trouble reaching us, please try again in a few minutes. Thank you for your patience.
Posted 2 months ago. May 13, 2018 - 04:29 PDT
Identified
We’re experiencing issues with our phone vendor and may be getting more calls than usual. If you have trouble reaching us, please try again in a few minutes. Thank you for your patience.
Posted 2 months ago. May 13, 2018 - 03:47 PDT