Ezidebit Real Time Transactions - Degradation
Incident Report for MINDBODY
Resolved
Ezidebit has resolved their incident and services have restored to full functionality.
Posted Nov 27, 2019 - 19:28 PST
Identified
EziDebit is currently experiencing issues with their real time payment processing gateway. MINDBODY clients using EziDebit may experience failed transactions when attempting to process payments. Please continue to monitor the MINDBODY Status Page for further updates.
Posted Nov 27, 2019 - 17:56 PST
This incident affected: Payment Processing.