Mindbody Web Software
Incident Report for Mindbody
Resolved
We have resolved the previous issue impacting Mindbody web software. Thank you for your patience as we worked to restore services.
Posted Sep 17, 2020 - 18:48 PDT
Investigating
We are currently investigating an issue with Mindbody web software impacting new staff log ins. Subscribers already logged in are able to continue to navigate the website.
Posted Sep 17, 2020 - 18:18 PDT
This incident affected: Mindbody Web Software.