MINDBODY Corporate Web
Incident Report for MINDBODY
Resolved
The incident has been resolved and customers are now able to access www.mindbodyonline.com. We apologize for the interruption-thanks for bearing with us!
Posted Feb 07, 2020 - 13:03 PST
Investigating
We are currently investigating an issue with our MINDBODY Corporate website.
Posted Feb 07, 2020 - 12:54 PST
This incident affected: MINDBODY corporate site.